diff options
author | Greg Brown <gmb60@cam.ac.uk> | 2021-03-02 16:08:26 +0000 |
---|---|---|
committer | Greg Brown <gmb60@cam.ac.uk> | 2021-03-02 16:08:26 +0000 |
commit | fa69e4edd87e3ec319ac4962c619b04e2203628e (patch) | |
tree | 1ef140e9c49cb1ee9ba327b574c69dac25fefdc9 /Cargo.toml | |
parent | 7934aa9af22e8fa3c33a45bc08e732a73c0cabf5 (diff) |
Introduce function types.
Function types are just functions from types to check-results. Nothing more than
delayed computation. Efficiency will initially be no better than current.
Caching results could help, but that's a future problem.
An alternative approach is introducing constraints. That would be a bigger
architectural change, with more complex processing. On the other hand, adding
future extensions would be easier.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -9,6 +9,7 @@ members = ["autochomp", "chewed", "chomp-bench", "chomp-macro"] [dependencies] heck = "0.3.2" +once_cell = "1.7.2" proc-macro2 = "1.0.24" quote = "1.0.8" syn = "1.0.58" |