summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChloe Brown <chloe.brown.00@outlook.com>2024-09-09 15:05:10 +0100
committerChloe Brown <chloe.brown.00@outlook.com>2024-09-09 15:05:10 +0100
commita42b01ce1e2534621add7bf8a399fb5be9fd060f (patch)
tree38c9b32b002489c4cd82ae99b0161d6df92586f5
parent39896168725599e2e2f5aa405e508e5f92dd1078 (diff)
network-manager-l2tp: new package
-rw-r--r--yellowsquid/packages/network.scm58
-rw-r--r--yellowsquid/packages/patches/network-manager-l2tp-fix-for-autoconf-2.69.patch48
2 files changed, 106 insertions, 0 deletions
diff --git a/yellowsquid/packages/network.scm b/yellowsquid/packages/network.scm
new file mode 100644
index 0000000..577b91e
--- /dev/null
+++ b/yellowsquid/packages/network.scm
@@ -0,0 +1,58 @@
+(define-module (yellowsquid packages network)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages nss)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages samba)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages vpn)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses)
+ #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (yellowsquid packages))
+
+(define-public network-manager-l2tp
+ (package
+ (name "network-manager-l2tp")
+ (home-page "https://github.com/nm-l2tp/NetworkManager-l2tp")
+ (version "1.20.16")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nm-l2tp/NetworkManager-l2tp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (patches (search-patches
+ "network-manager-l2tp-fix-for-autoconf-2.69.patch"))
+ (sha256
+ (base32 "1f2n4wayf7dw6a04krdaj225pzra9xl72yzna4v5s017fp3wxi7g"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf
+ automake
+ gettext-minimal
+ (list glib "bin")
+ gobject-introspection
+ libtool
+ pkg-config))
+ (inputs (list gettext-minimal
+ gtk+
+ libnma
+ libsecret
+ network-manager
+ nss
+ openssl
+ ppp
+ strongswan
+ xl2tpd))
+ (synopsis "L2TP plugin of NetworkManager")
+ (description
+ "This extension of NetworkManager allows it to take car of connections
+to virtual private networks (VPNs) via L2TP and L2TP/IPSec.")
+ (license license:gpl2)
+ (properties `((upstream-name . "NetworkManager-l2tp")))))
diff --git a/yellowsquid/packages/patches/network-manager-l2tp-fix-for-autoconf-2.69.patch b/yellowsquid/packages/patches/network-manager-l2tp-fix-for-autoconf-2.69.patch
new file mode 100644
index 0000000..46063e7
--- /dev/null
+++ b/yellowsquid/packages/patches/network-manager-l2tp-fix-for-autoconf-2.69.patch
@@ -0,0 +1,48 @@
+From 3969c8db87aed6d41b945573c269cd09bc7e3179 Mon Sep 17 00:00:00 2001
+From: Douglas Kosovic <doug@uq.edu.au>
+Date: Wed, 29 May 2024 21:17:37 +1000
+Subject: [PATCH] build: Fix for autoconf 2.69
+
+Generated configure script had syntax error when autoconf 2.69's
+autoreconf was used.
+---
+ configure.ac | 17 ++---------------
+ 1 file changed, 2 insertions(+), 15 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 98f63c0..4b23cb9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -52,27 +52,14 @@ dnl
+ dnl Required headers
+ dnl
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS([
+- fcntl.h
+- paths.h
+- stdarg.h
+- stdbool.h
+- sys/ioctl.h
+- sys/time.h
+- syslog.h
+- unistd.h
+- ])
++AC_CHECK_HEADERS([fcntl.h paths.h stdarg.h stdbool.h sys/ioctl.h sys/time.h syslog.h unistd.h])
+
+ AC_CHECK_HEADERS(pppd/pppd.h,,
+ AC_MSG_ERROR(couldn't find pppd.h. pppd development headers are required.))
+
+ dnl
+ dnl Check the presense of other pppd/*.h files
+-AC_CHECK_HEADERS([
+- pppd/chap.h
+- pppd/chap-new.h
+- pppd/chap_ms.h
+- ])
++AC_CHECK_HEADERS([pppd/chap.h pppd/chap-new.h pppd/chap_ms.h])
+
+ dnl
+ dnl Versions >= 2.5.0 will have pkg-config support
+--
+2.46.0
+