summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChloe Brown <chloe.brown.00@outlook.com>2022-01-10 14:58:13 +0000
committerChloe Brown <chloe.brown.00@outlook.com>2022-01-10 14:58:13 +0000
commitb32843ce6cac1d36fdfa7051549e4db7fc5a803c (patch)
tree5ca6cc0f59d4505991962a1c231b9b31af5cdecf
parent3c5cd4ff81f1ae2c8f92f76870770f8f6b5614c5 (diff)
swaylock-pam: Add pam to swaylock
-rw-r--r--yellowsquid/packages/swaylock.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/yellowsquid/packages/swaylock.scm b/yellowsquid/packages/swaylock.scm
new file mode 100644
index 0000000..4bdeba0
--- /dev/null
+++ b/yellowsquid/packages/swaylock.scm
@@ -0,0 +1,64 @@
+(define-module (yellowsquid packages swaylock)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages man)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xdisorg)
+ #:use-module (guix build-system meson)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public swaylock-pam
+ (package
+ (name "swaylock")
+ (version "1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/swaywm/swaylock")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r95p4w11dwm5ra614vddz83r8j7z6gd120z2vcchy7m9b0f15kf"))))
+ (build-system meson-build-system)
+ (inputs (list cairo gdk-pixbuf libxkbcommon linux-pam wayland))
+ (native-inputs (list pango pkg-config scdoc wayland-protocols))
+ (home-page "https://github.com/swaywm/sway")
+ (synopsis "Screen locking utility for Wayland compositors")
+ (description "Swaylock is a screen locking utility for Wayland compositors.")
+ (license license:expat)))
+
+(define-public swaylock-effects-pam
+ ;; Latest release is from November 2020, but doesn't support disabling SSE.
+ (let ((commit "5cb9579faaf5662b111f5722311b701eff1c1d00")
+ (revision "1"))
+ (package
+ (inherit swaylock-pam)
+ (name "swaylock-effects")
+ (version (git-version "1.6-3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mortie/swaylock-effects")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"))))
+ (arguments
+ `(#:configure-flags '("-Dsse=false")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-meson
+ (lambda _
+ (substitute* "meson.build"
+ (("'-mtune=native',") "")))))))
+ (synopsis "Screen locking utility for Wayland compositors with effects")
+ (description "@code{Swaylock-effects} is a fork of swaylock with additional
+features, such as the ability to take a screenshot as the background image,
+display a clock or apply image manipulation techniques to the background image.")
+ (home-page "https://github.com/mortie/swaylock-effects"))))