summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChloe Brown <chloe.brown.00@outlook.com>2024-10-25 14:22:31 +0100
committerChloe Brown <chloe.brown.00@outlook.com>2024-10-25 14:22:31 +0100
commitf0a69b522c09218e09f6c1d39decab66e1de3848 (patch)
tree8ef58570ae4cd62d9432d93bc4dc4c56d9b62a28
parented8ba9a77ea1891c5a729e7bbfa3058bf0ba8e6e (diff)
idris2: update git revision.
-rw-r--r--yellowsquid/build-system/idris.scm2
-rw-r--r--yellowsquid/packages/idris.scm17
-rw-r--r--yellowsquid/packages/patches/idris2-no-support.patch27
3 files changed, 38 insertions, 8 deletions
diff --git a/yellowsquid/build-system/idris.scm b/yellowsquid/build-system/idris.scm
index 135fa83..f679f2f 100644
--- a/yellowsquid/build-system/idris.scm
+++ b/yellowsquid/build-system/idris.scm
@@ -20,7 +20,7 @@
(define %idris-build-system-modules
`((yellowsquid build idris-build-system)
- ,@%gnu-build-system-modules))
+ ,@%default-gnu-imported-modules))
(define %default-modules
'((yellowsquid build idris-build-system)
diff --git a/yellowsquid/packages/idris.scm b/yellowsquid/packages/idris.scm
index d00b635..2d8963e 100644
--- a/yellowsquid/packages/idris.scm
+++ b/yellowsquid/packages/idris.scm
@@ -10,7 +10,8 @@
#:use-module (guix utils)
#:use-module (ice-9 regex)
#:use-module (srfi srfi-9)
- #:use-module (yellowsquid build-system idris))
+ #:use-module (yellowsquid build-system idris)
+ #:use-module (yellowsquid packages))
(define-record-type <idris-source>
(idris-source origin version tag guix-version)
@@ -267,9 +268,11 @@
"https://github.com/idris-lang/Idris2")
(commit commit)))
(file-name (git-file-name "idris2" guix-version))
- (sha256 (base32 hash))) version
- (substring tag 4)
- (string-append version "-" tag))))
+ (sha256 (base32 hash))
+ (patches (search-patches "idris2-no-support.patch")))
+ version
+ (substring tag (1+ (string-index tag #\g)))
+ (string-append version "-" tag))))
;; The earliest idris we can build
@@ -298,9 +301,9 @@
;; Latest git commit
(define %idris-source-git
- (idris-git-source "0.7.0" "034f1e89c4c58cdd59aabe2b0d0fe4e9ff3411f6"
- "50-g034f1e89c"
- "1b6yvarydyk2m1q82hg96f2rfywda42i4cw66jzbm71fvg84ya2k"))
+ (idris-git-source "0.7.0" "0659bcc2c0c8b437affd9d33b62668f0b08c74f7"
+ "268-g0659bcc2c"
+ "1chjy0gnrsgb205rhxridbpp7nf72922mg1cx6mg1gkl9z97ad1j"))
(define-public idris2-support-git
(package
diff --git a/yellowsquid/packages/patches/idris2-no-support.patch b/yellowsquid/packages/patches/idris2-no-support.patch
new file mode 100644
index 0000000..b49afdd
--- /dev/null
+++ b/yellowsquid/packages/patches/idris2-no-support.patch
@@ -0,0 +1,27 @@
+From 0ca600f7f0edc231c9335f9df710408ce852703c Mon Sep 17 00:00:00 2001
+From: Chloe Brown <chloe.brown.00@outlook.com>
+Date: Fri, 25 Oct 2024 13:53:34 +0100
+Subject: [PATCH] Do not install support when installing Idris.
+
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 1e828cf88..9e6e6195c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -195,8 +195,8 @@ clean: clean-libs clean-support testenv-clean
+ ${MAKE} -C tests clean
+ $(RM) -r build
+
+-install: install-idris2 install-support install-libs
+-bootstrap-install: install-idris2 install-support install-bootstrap-libs
++install: install-idris2 install-libs
++bootstrap-install: install-idris2 install-bootstrap-libs
+
+ install-api: src/IdrisPaths.idr
+ ${IDRIS2_BOOT} --install ${IDRIS2_LIB_IPKG}
+--
+2.46.0
+