summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChloe Brown <chloe.brown.00@outlook.com>2022-08-01 13:56:34 +0100
committerChloe Brown <chloe.brown.00@outlook.com>2022-08-01 13:56:34 +0100
commitf77424d5f4c4a384d6422d49bd78144e6775fd06 (patch)
treef8cde831a101adde4f8b52fe1fb0e8be201c82b4
parent3ad828eb5800bf33fdbae0861c434e3bb504614b (diff)
exim: new package.
Repackage exim, with the following changes: - add /etc/exim.conf as a trusted configuration location. - enable LMTP transport.
-rw-r--r--yellowsquid/packages/mail.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/yellowsquid/packages/mail.scm b/yellowsquid/packages/mail.scm
new file mode 100644
index 0000000..cd980ce
--- /dev/null
+++ b/yellowsquid/packages/mail.scm
@@ -0,0 +1,19 @@
+(define-module (yellowsquid packages mail)
+ #:use-module ((gnu packages mail) #:prefix gnu:)
+ #:use-module (guix gexp)
+ #:use-module (guix packages)
+ #:use-module (guix utils))
+
+(define-public exim
+ (package
+ (inherit gnu:exim)
+ (arguments
+ (substitute-keyword-arguments (package-arguments gnu:exim)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'configure 'configure-more
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Local/Makefile"
+ (("# (TRUSTED_CONFIG_LIST=).*" all var)
+ (string-append var "/etc/exim.conf\n"))
+ (("# (TRANSPORT_LMTP=yes)" all line) line))))))))))