summaryrefslogtreecommitdiff
path: root/chomp-macro/Cargo.toml
diff options
context:
space:
mode:
authorGreg Brown <gmb60@cam.ac.uk>2021-01-09 14:31:02 +0000
committerGreg Brown <gmb60@cam.ac.uk>2021-01-09 14:31:02 +0000
commit0d01692c97ea8ca6fc4b229e5b9678cb252bceda (patch)
tree6c5ed07740b814f50dddbc6afaefc21c11dc3440 /chomp-macro/Cargo.toml
parent487ce4fe0fa081f58d790d7d6417bf7d2659197c (diff)
Introduce chomp as a procedural macro.
Add a bunch of tests. Fix chomp and chewed so autochomp compiles.
Diffstat (limited to 'chomp-macro/Cargo.toml')
-rw-r--r--chomp-macro/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/chomp-macro/Cargo.toml b/chomp-macro/Cargo.toml
new file mode 100644
index 0000000..bc8dce0
--- /dev/null
+++ b/chomp-macro/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "chomp-macro"
+version = "0.1.0"
+authors = ["Greg Brown <gmb60@cam.ac.uk>"]
+edition = "2018"
+
+[dependencies]
+chomp = {path = ".."}
+
+[dependencies.syn]
+version = "1"
+features = ["parsing", "proc-macro"]
+
+[dev-dependencies]
+chewed = {path = "../chewed"}
+
+[lib]
+proc_macro = true