summaryrefslogtreecommitdiff
path: root/chomp-macro/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'chomp-macro/Cargo.toml')
-rw-r--r--chomp-macro/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/chomp-macro/Cargo.toml b/chomp-macro/Cargo.toml
new file mode 100644
index 0000000..bc8dce0
--- /dev/null
+++ b/chomp-macro/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "chomp-macro"
+version = "0.1.0"
+authors = ["Greg Brown <gmb60@cam.ac.uk>"]
+edition = "2018"
+
+[dependencies]
+chomp = {path = ".."}
+
+[dependencies.syn]
+version = "1"
+features = ["parsing", "proc-macro"]
+
+[dev-dependencies]
+chewed = {path = "../chewed"}
+
+[lib]
+proc_macro = true